9 lines
222 B
Nix
9 lines
222 B
Nix
{ pkgs ? import <nixpkgs> {},
|
|
bash,
|
|
deno,
|
|
}: let
|
|
src = ./.;
|
|
in pkgs.writeScriptBin "blogbot" ''
|
|
#!${bash}/bin/bash
|
|
${deno}/bin/deno --allow-net --allow-read --allow-write --lock ${src}/deno.lock ${src}/mod.ts
|
|
''
|